Star Wars Episode I: The Phantom Menace Patch 1.1

This patch is for Star Wars Episode I: The Phantom Menace

  • Last Updated: Sep 17, 2009
  • License: Freeware / Free
  • OS: Windows XP, 2000, 98, Me, NT
  • Publisher: LucasArts

Description of Star Wars Episode I: The Phantom Menace Patch 1.1

Advertisement
Upgrade to version 1.1. This patch addresses the error that occurs when selecting Joystick Option and Video Options under Hardware Configuration on the game's launcher when using DirectX 7.
Requirements: No special requirements

Special Game Zone

Publisher's Product(s)

> > More Publisher's Products

New Games Released

Bookmark Star Wars Episode I: The Phantom Menace Patch 1.1